Snippet

Snippet tab lets you write some code in the lower TextArea as if you were in the Main of a class.

Console output is redirected to the upper pane.

Example

Console.WriteLine("Hello World!");

Output

Hello World!


Console

Console let's you evaluate expressions. Just write it in the lower TextBox and press Enter.

With up/down keys you can recall previous inserted expressions.

Example

1 + 3

Output

4


RegEx

RegEx tab let's you test your regular expressions. You can write your regex in the top pane and the expression to be tested in the lower pane.

If regex turns red, it mean it's malformed. If the expression to be tested turns red, it means it doesn't validate against the provided regular expression.

Example

^\d{1,5}$

Output

Matches: 0 12345 Doesn't match: 123456 abc


Xml

Xml tab let's you validate some xml code and optionally also against an xml schema.
In the error list tab you can find the result of the validation.
If something turns red, then check out the list to see what's wrong.

Example

// XML
<author xmlns='urn:bookstore-schema' xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance'>
<first-name>Eugenio</first-name>
<last-name>Favalli</last-name>
</author>

// XML schema
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns="urn:bookstore-schema" elementFormDefault="qualified" targetNamespace="urn:bookstore-schema">
<xsd:element name="author" type="authorName"/>
<xsd:complexType name="authorName">
<xsd:sequence>
<xsd:element name="first-name" type="xsd:string" />
<xsd:element name="last-name" type="xsd:string" />
</xsd:sequence>
</xsd:complexType>
</xsd:schema>